Notifications
Clear all

Why are most of the columns of the protein summary never populated? Like gene ontology, pathway, protein families, etc

 

We use ProteinPilot v5.0 and search against the uniprot database+contams. We have never seen any protein descriptive columns populated in any of our searches. Why is that? What does it take to get that information in our search results?

PP v5.0 protein summary screenshot

Quote
Posted : October 19, 2018 11:57 am
christie.hunter@sciex.com
Member Admin

For this service to work, you need to be using UniProt/SwissProt databases, which it looks like you are.

Also you need to be connected to the internet. So after protein grouping, ProteinPilot will ping the UniProt server and pull back the ontologies for the detected proteins.  Can you confirm you can reach this site from your ProteinPilot workstation?  http://www.uniprot.org.   

ReplyQuote
Posted : October 19, 2018 12:22 pm

Interesting...I had always thought that maybe it was just some service that we weren't paying for, like the early days of ProteinPilot v1 where you had to have a subscription to some fancy database. We have never had any protein description or feature information in ProteinPilot results when searching SwissProt/Uniprot databases, even when we ran earlier versions of PP (3.0, 4.0). I clicked on the uniprot link and it opens no problem, we always have internet connectivity. I wonder why it doesn't work.

ReplyQuote
Posted : October 19, 2018 3:23 pm

After in depth discussions with Sciex about the same issue, we discovered this was because the data is pulled from Uniprot who changed their API recently to use https rather than http - without an update to PP5 which accounts for this change, the data will not populate.

 

"We supported separate HTTP and HTTPS services until release 2018_06 (June 20, 2018). From this date, the HTTP traffic is automatically redirected to HTTPS. We intend to maintain these redirects indefinitely, but it is to your advantage to update your applications to use HTTPS as soon as possible, both for performance and security reasons."

ReplyQuote
Posted : October 22, 2018 5:32 am

Hi David,

Thank-you for the information. In fact, we were never able to get this feature to work, even before June 2018. But now it seems unlikely that it will no matter what we try to do until Sciex updates ProteinPilot to ping https rather than http, is that what you are saying? Did Sciex give you any feedback on when an update or fix for this issue is coming? 

cheers,

Leanne

ReplyQuote
Posted : October 22, 2018 10:14 am

Hi Leanne, that was my understanding from SciexNow - they said it'd need a new release to patch it in, and no timescale was given.

ReplyQuote
Posted : October 22, 2018 10:35 am
christie.hunter@sciex.com
Member Admin

The https issue was resolved in ProteinPilot 5.0.2 version (up on SCIEX Software downloads page). However it looks like there has been yet another change made, we are digging in on that. Stay tuned!

ReplyQuote
Posted : October 22, 2018 11:00 am
Share: